Error importing a workflow: Problem importing workflow Could not find property option

I am migrating from N8N desktop to Cloud (Railway) and I could not import my workflow into Railway.
Kindly assist.


My workflow has telegram, Supabase, https nodes.

  • Version - Downloaded online on 27-Jan-20204
  • desktop app
  • Windows 11

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Jackson_beno

Welcome to the community!

What way do you use to import the workflow?
Have you tried simply selecting the whole workflow and pasting it into a new workflow on the cloud hosted version?

Hi BramKn,
Yes, I tried that but still same error.

I have isolated the problem now,
the problem is with this particular switch node.
I’m not sure what is wrong with this switch node.

I’m able to paste it into my desktop app but unable to paste it into Railway N8N.

very weird, probably has to do with the new switch node that was introduced.
Normally it would just use the old version, but something is not right with that then.
If you just have a few workflows, just transfer them manually and put in the new switch node.

This will be fixed in the next release, There is currently an issue when importing workflows that contain a v2 switch node.


I have the same issue, my workflow also contain Switch node, my version 1.26.0


Hey @shek,

Can you try updating, This should be fixed in 1.27.0 so any recent version should be all good.

their github shows it is updated to now 1.28.0

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.