Error in running a loop

Describe the problem/error/question

We tried to build a loop to query with some data in our internal server within the past 30 days, to avoid a large amount of data, we tried to separate it into 30 times(querying the data day by day, nearly 30-60 items each), the workflow has worked before, however, after we update the n8n version to the latest version, the workflow crashed every time we execute it, the UI was not responsible and the workflow would never be finished. The issue remains even we added the memory and adjusted with the NODE_OPTIONS=–max_old_space_size variable. What we did is we tried to roll back the n8n version to 1.10.0 and it works finally.

What is the error message (if any)?

The workflow crashed after the execution. No error message could be shown and the docker crashed and restarted afterward, however, we could not reach the UI again after it crashed.

Please share your workflow

Below please find our workflow

Share the output returned by the last node

No output could be found as it crashed.

Information on your n8n setup

  • **n8n version: 1.11.1
  • **Database (default: SQLite): SQLite
  • **n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • **Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • **Operating system: Ubuntu

Hi @ansonchl :wave: Welcome to the community :tada:

Thanks for posting all of that information - maybe @netroy can shed some light here on as to why this is working for you in 1.10.1 but not 1.11.1, and what may have changed to memory consumption being increased :bowing_man:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.