ERROR: Invalid 'name' syntax for columns with space


I want to INSERT data into my Postgres database and it works all fine until I use column names that include spaces (like Meta DR)

I get the error message

ERROR: Invalid ‘name’ syntax: “Meta DR”:

I know that I have to put them in quotes when I work directly with Postgres.
I also tried to put them in quotes in n8n, but the error message still appears.

Any idea how to fix that? Thanks in advance

Hey @passana, welcome to the community :tada:

I had a quick go at this and was able to confirm the behaviour (and have added it to our internal bug tracker for a closer look by the engineering team).

As for now, inserting a new row did work fine for me when using the node’s Execute Query operation instead of Insert.

Example Workflow

Could you give this a go on your end and let me know if you are still facing trouble afterwards?

Thanks @MutedJam for your response.

I will try and let you know

I have the same issue here…

Hi @enzopolo, could you try my suggestion above of using the Execute Query operation and confirm whether this works for you?

@MutedJam this worked fine, thanks a lot!

1 Like

Fix got released with [email protected]

Hi,I am using the desktop client version 0.204.0 ,facing same issue(Insert/Update fails for column names that include spaces )with a MySQL database.

The Execute Query works but it will be great if there is a fix for the ‘Update’ and ‘Insert’ Operations.

Hi @ReadyP1, welcome to the community and sorry for the trouble!

I was able to reproduce this problem and have added it to our engineering backlog for a fix. We will, of course, confirm once this fix is available.

Going forward, could you open a new topic in case you encounter any new issues? Responses in old topic tend to get overlooked, especially when they confirm different nodes. Thank you so much :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.