Error: No refresh token

I get an “Error: No refresh token” notice when I try to connect to the ClickUp API using OAUTH2.


I didn’t see anything related to this on Github or searching this site.
What do you recommend?

1 Like

Just tested and it’s working fine for me. Really weird. Are you still having the issue?

Yes. Here’s an updated screenshot. Could this be a configuration issue?

Hey @Josh_Fialkoff!

I tested this and it works fine for me too. Can you try to re-configure the credentials? Also, you can use the Access Token authentication method with the nodes.

@Josh_Fialkoff yes please try to reconnect the credentials. That can be done by opening the credentials and then pressing on the orange button with the arrow left of “Connected”.
Screenshot from 2020-12-04 08-55-18

If that does not work please create new credentials and connect them.

This error is a little bit confusing as according to their documentation the access token should never expire:
Screenshot from 2020-12-04 08-59-11
Here the link:

The refresh token does however only get used if the API returns a 401 which means “unauthorized”. It gets returned if the used access-token is not valid anymore. Which like linked above, should not happen. The error message makes sense as they probably do not return a refresh-token if access-tokens do not expire as they are not needed.
Anyway so for me, it looks like they either expire after all or there is maybe something else at play. Do not know ClickUp but do they have for example a sophisticated user-management where it can be restricted what each account is allowed to do? Because if you do something that you are not allowed to do they maybe return also 401 instead of the normal for that correct 403. But just grasping at straws here.

Same error instantly after creation new credentials

Hey @maxbaluev

I created credentials a couple of hours back and it worked well for me. Can you please try creating them once again? Here’s a video that might help

@harshil1712

I just tested it once again. It looks like the ID you’re passing is incorrect. Sadly the error response given by ClickUp is not helpful. Can you please try the Get All operations to make sure that credentials are working?

After running getAll, get now worked, but rebooting didn’t help!

The next day it happened again for no apparent reason, calling the Create method instead of the Get method.

Are you passing any ID in the ID field? Your screenshot doesn’t show any ID.

Yes, this is incorrect screanshoot from debugging. Actual:

And i have troubles with access token too:

Nothing is googled for the error, both clickup authorization methods fail :frowning:

PS: @jan This is similar to the scalability issues in Kubernetes

@jan And no, when you scale to one container - the problem repeats.

Hey @maxbaluev,

Can you share the expression you are passing in the ID field? I tested it with the Access Token credentials, and if the ID is incorrect I get the same error as you. But if the ID is correct the node executes successfully.

@harshil1712 After If node:


This is strange. The expression looks good, and it is working for me. I tried running it locally, on n8n.cloud as well my self-hosted version. If the ID you’re passing is correct then you should not get the error. I only get this error when I pass the wrong ID. Does a Task with that ID exist?

Replacing the id with a string solves the problem. In the end, the checkbox execute once solves the problem exactly the same way, just displays an incorrect error.