ERROR: RequestError: Error: connect ETIMEDOUT

Can I ask for some help with a scenario I am running

The ITERATOR node is doing this:

return items[0].json.objects.map(item => {
  return {
json: item
  }
});

The problem I am getting is with the ENRICH API HTTP query node.

The VALUE field is taking the IP out of each iterator node before and then using that to do another API look up (well that’s the intention)

then get this error

Am I doing something wrong, or anyone knows a solution to this at all?

Regards

If it times out you can simply increase the timeout time. Add on the HTTP Request node under “Options” -> “Timeout” and set it to a higher value. It will then wait longer before it times out. But honestly, unless the API or network is super slow that should normally not be needed. So is definitely strange that it times out in the first place.

If that does not help it is also possible that the API has some kind of rate-limiting and if you send too many requests it maybe simply does not respond anymore. In this case, you can try adding on the HTTP Request node under “Options” the following:

  • Batch Interval: 1000
  • Batch Size: 1

It will then make 1 request per second. If that works you can try to decrease the batch interval and increase batch size. But probably best to check the API documentation to find the actual values.

Hope that helps!

1 Like

Hey Jan,

Thanks for the ideas, i will give it a go and report back. Aslo I didn’t think about rate limiting, I will check the API docs.

Good luck :crossed_fingers:

batch interval and size fixed it, there was no mention of rate limiting in the API docs!

So glad it wasnt me that was messing it up, thanks so much for the help!

1 Like

Glad to hear that it helped. Have fun!