ERROR: Session must be a buffer Session must be a buffer - [WordPress]

currently using latest docker image.

I have started to get this error when making a POST request to upload an image to WordPress via REST API.


NodeApiError: Session must be a buffer
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/HttpRequest/V1/HttpRequestV1.node.js:851:27)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:646:28)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:631:53

Not sure if this is a n8n error or something weird that has happened somewhere else recently. Any thoughts ? As it has been working fine until recently.

Hey @RedPacketSec,

What version of n8n are you running? I am aware of one other report of this issue which has also come from using the HTTP Request node. It looks like you are using the v1 node as well have you tried adding a new http request node to see if that has the same issue?

I’m using 1.0.5 (latest docker tag) and just selected an HTTP node from the menu

Interesting the error shows v1 :thinking:

Can you share the workflow?

its just a single HTTP node taking a file from the node before (a .png)

then trying to upload into Wordpress via HTTP Node

now im getting it in more HTTP nodes in other flows:

Error Message: Session must be a buffer
Node Causing Error: WordPress Search Slug (HTTP Request Node)

I’ve just tried adding NEW http request node and making wrong request

I can see that the node version is already V3 (my n8n version is 0.234.x).
Maybe in your case it would help if you just place a new HTTP request node and configure it the same as the old one?

NodeApiError: connect EADDRNOTAVAIL ::1:80 - Local (:::0)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/HttpRequest/V3/HttpRequestV3.node.js:1253:27)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:652:28)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:596:53

I’ve seen this error in the past, and I managed to narrow it down to some kind of SSL issue on nodejs 18.

Is there a public url that you could share with us, that I can reliably reproduce this issue on?

In the meanwhile, I recommend enabling the “Ignore SSL Issues” option on the node.


ignore SSL issues is the fix.

How weird, wonder what the cause of this is, def not an issue with the cert from my website.

ah man, does this now mean i have to go and edit all my HTTP nodes to ignore SSL… this is not going to be fun :frowning:

If you can share a url with me where I can reproduce this reliably, I might be able to add a fix for the issue instead, so that you might not have to ignore SSL issues everywhere.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.