ERROR: SSL Issue: consider using the 'Ignore SSL issues' option

Describe the problem/error/question

Folderit is a Document Management System, they are using amazon servers for storage.
When calling https://api.folderit.com/v2/accounts/{accountUid}/files/{fileUid}/download it checks Ouath2 Header auth and redirects me to amazon link.

Since upgrading to 1.27.3, I am reciving an ERROR: SSL Issue. I am guessing because of this: fix(core): Use hostname from URL instead of Host header for SNI by elsmr · Pull Request #8562 · n8n-io/n8n · GitHub

Options: Ignore SSL Issues dosen’t do anything.

Is there any workaround or should I just go to older version of n8n?

Please share your workflow

Information on your n8n setup

  • **n8n version:1.27.3
  • **Database (default: SQLite):SQLite
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):own
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):Docker Compose
  • **Operating system:Ubuntu

Hi @Nejc_Lukacek :wave: Scratch what I said before, this should be fixed in the 1.30.0 :tada: Releases · n8n-io/n8n · GitHub