ERROR: The provided field 'xxxxxx' is not an array

Quick question, what am i missing here?


SET1 Node:

Item Lists1

Hey @RedPacketSec,

What happens if you don’t use an expression for the Item List node?

same result

Any chance of a sample workflow that I can play with?

sadly not, but all i can says its its Qualys json converted from xml

That is going to make it a bit tricky :smile:

I have given it a quick go here but I have not been able to produce the same result, I found some sample XML data on the Qualys Github repo which I have forked to remove a bit of the help info.

Does the below workflow run ok for you and are you able to tweak it to match the steps leading up to your item list?

Example Workflow

this works

Does it help at all with your issue?

I am not sure what else yours is doing but maybe it is something with the data itself :person_shrugging:

Is it the correct data source type? It looks like there are a few different sample outputs so if needed I can play with a different one.

maybe its the same thing im doing, maybe there is too much data?

I would be surprised if too much data causes the issue, I have just updated that file so it contains 5916 items and it seems to have handled it.

What I have just noticed though is you have 641 items going into your Item Lists node, Could you pop an if before the item lists node to make sure the data is an array before passing it to the items list it could be that you have one bit of data in the 641 inbound requests that isn’t an array.

Is it possible that some of the items return correctly an array (as the first item does) but others do not?

1 Like

hmmm potentially… which would be a pain

I guess to start with start checking with an If then you can check the false output to see what you are getting and if needed tweak it from there.

I have had another play and if I have a file with one Detection item it does show as not being an array, If you use the workflow from yesterday and change the github URL to you can see what I think is happening.

yes this does seem to have a similar outcome

1 Like

I suspect that will be it then, So it would be a case of validating / checking the data first and working from there. As it isn’t an array and is already an object you could probably go to the next action and you could also have your item list node go into the same action as the data should be the same.

be handy for the list item tool to be able to handle both

1 Like

That is not a bad idea and would be worth a feature request, Personally I would prefer to check my data as there could be a fault if it is not in the format I am expecting.

i believe there is already one