ERROR: Unable to sign without access token

Hello,
I recently had some issues with n8n and had to reinstall, I was able to export my workflows but not my credentials. After installing the latest version of n8n and importing my old workflows, I am unable to use a connection that I was previously using. It is a graphql node and the error I am getting is

I have the same credentials in a postman workspace and am able to get a token using OAuth 2.0 just fine, I tried recreating the workflow from scratch and am still getting the same error.

Information on your n8n setup

  • n8n version: 0.211.2
  • Database you’re using (default: SQLite):SQLite
  • Running n8n with the execution process [own(default), main]:main
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]:Docker

Hi @Matthew_Gomes, can you try re-creating the credentials from scratch you are using in your workflow? I wonder if this might simply be a case of your new instance using a different encryption key for credentials.

Hey, I’m running into the same issue running n8n version 0.212.0.

I just upgraded and have recreated my credentials, and still no difference.

I’m testing it with a node I’m developing which extends the oAuth2Api module. Has this changed in the recent updates?

Hey @Faintiz,

No changes I am aware of, Do other oauth credentials work?

Apologies for the late response, I tried recreating the credentials and the same issue occurs. I thought it may have been the fact that I went from the ‘n8nio/n8n:latest-debian’ image to ‘n8nio/n8n:latest’ so I tried again with the ‘n8nio/n8n:latest-debian’ image and it still did not work, recreated the credentials after changing images. This issue has me stumped.

Hey @Matthew_Gomes,

Which Grant Type are you using? A bug came up recently with the Client Credentials option which I put in a fix for a couple of days ago that will be in the next release so I am wondering if maybe it is that.

If you are using Authorization Code it could be something else.

I am indeed using Client Credentials, hopefully your fix solves it.