Error using DynamoDB Node - Cannot read property 'message' of undefined

I am trying to use all the operations in DynamoDB node, but it gives this error everytime.

ERROR: Cannot read property ‘message’ of undefined

My n8n version is 0.144.0

Hey @zocket,

When you see Cannot read property X of undefined it tends to mean something doesn’t exist so in this case it is trying to get the “message” property from a value that isn’t set / doesn’t exist. Could it be the key condition causing the issue or is the table empty?

I also tried using set node. With all the options in Data to Send field. It still had the error.

I tried reading data from the table, it also brought the same error.

The database has values(it isn’t empty). I don’t know why it doesn’t also read the table data too

or is it maybe a bug with the node perhaps?

Just tested it and it works fine (Check image below). You have to define the expression attribute value. You are adding :testing but what is the value that that label is going to take?

Thanks, my bad I didn’t add the “Express Attributes Values”

It’s now good. Thanks for the help and example.