Error while building the "create-your-first-node" due to [email protected]^7.32.0 version

Hi devs and @jan , first of all thanks on providing the source-code available for all devs to creating impressive workflows .

i am currently facing issues while running the steps to build the first node . i followed all the steps mentioned and defined *.node.ts , but at the stage of build and creating bootstrap , i am facing issues due to the build dependencies of eslint along with vue , the logs are as follows :

npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: [email protected]
npm ERR! Found: [email protected]
npm ERR! node_modules/eslint
npm ERR!   dev [email protected]"^7.32.0" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer [email protected]">= 1.6.0 < 7.0.0" from @vue/[email protected]
npm ERR! node_modules/@vue/cli-plugin-eslint
npm ERR!   dev @vue/[email protected]"~4.5.0" from the root project
npm ERR! 

i did tried to fix via install --legacy-peer-deps , or via the downgrading the version , but still the problem persists . i am building on the latest version (commit : 4db91d55dd44a8639612512c0b81781874f517b7 ) . thanks for help in advance and feel free to ask further information .

Welcome to the community @Dhruv !

Sorry to hear that you have problems. I did just check out n8n totally fresh following this guide and for me, it worked totally fine. So I assume you do not use a supported versions of Node.js or npm. Please make sure that you use Node.js v14 and npm v6. I for example, did test with [email protected] and [email protected]

Please test with that versions. If also that does not work please tell us which operating system you are using.

If your versions are correct, then try:

npm run clean:dist; rm -rf node_modules; lerna bootstrap --hoist; npm run build

Hey @Dhruv,

Is your issue resolved? If yes, can you please share the solution? This would help others with the similar issue find solution faster