Excel connector not working (I think)

Describe the problem/error/question

I’m trying to update an excel table, but I cannot get it to work. When I run the node, nothing is returned. I dont even know where it is looking, or how this working, very confusing!

What is the error message (if any)?

Please share your workflow

Further more, in the from if I try to get columns, there is nothing in the list?

Hi @Wayne :wave:

This looks like it might be a credential / permissions issue - are you part of an organisation that might need to give you additional permissions, or are these files all shared with the account you’ve connected to Microsoft with?

Hi @EmeraldHerald

I have global admin rights to the org I’m working with. I’ve set up the app registration on the Azure Portal will all relevant permissions.

The service account I’m using holds the files I need to access and is granted permissions.

I can get everything if I have the id’s for the files, workbook and tables I need (so this confirms I have permission), which isn’t idea as the table id are not an output anywhere in n8n, so I had to use Power Automate and the copy the id’s from their platform!

Would be nice if n8n returned what I needed.

Hi @Wayne - can you show me what you had to do in Power Automate? I’d love to have that information to pass on to our Product team, and I’ll mention @sirdavidoff here, too.

Hi @Wayne,

I have just given this a go with my own account and for me if I use Workbook > Get Many I get the data in the response.

The same with Table > Get Columns

When it fails to return anything does anything appear in the n8n log or the browser console? Can you also confirm which version of n8n you are using and how you have it deployed? I can’t think of a reason as to why this would work for my account so it could be an Azure setting. As a test can you take the workflow below and change the credential to use yours and give it a run to see if it outputs any body data.

You should get something like this if it is working…

1 Like


The HTTP request returns the following for me, not values are output:

I’m using n8n 1.1.1, deployed on railway.

The excel nodes doesn’t return anything, not even in the console.

I’ve enabled all the azure permission I can think of this:

Hey @Wayne,

That output of the HTTP request will be what we see in the node, If you look at the Body the value is an empty array which means the Microsoft API is not returning any workbooks owned by your user account. This will probably be why the node returns nothing and there is nothing in the drop down list as well, Sadly this isn’t something we control as we just use the APIs provided.

Based on this though I do have to ask… Does your Microsoft account own any of the workbooks you are trying to access or are they owned by other org members?

Yes I’m using the same account I used created the workbooks and I can see the workbooks in the OneDrive account of the user, so it’s strange it isn’t working.

Hey @Wayne,

It is very strange, It could be worth dropping a support email to Microsoft to ask them why their API is not returning the data. From what I can see the endpoint we use is user specific but if you have made the files they should be appearing :thinking:

Do the files exist in your personal one drive space?

Yes all in the user folder and sub folders

@Wayne could you try the below workflow and let me know if it outputs data, The difference here is rather than looking for items directly in your users folder it will look for any files that your user has access to.


Still returned nothing.

I’ve even tried through the Microsoft graph explorer and get the same results, which is strange. Clearly not confined to n8n.

Something funny going on with my clients tenant maybe!

This works: https://graph.microsoft.com/v1.0/me/drive/root/children
and do does this: https://graph.microsoft.com/v1.0/me/drive/recent


Ok so I’ve got it working but I had to use:


“requests”: [
“entityTypes”: [
“query”: {
“queryString”: “.xlsx”

probably not much use for your nodes :frowning:

Hey @Wayne,

That is odd but it is interesting to know that something works, Is your account actually part of the tenant or are you on a reseller account with multiple tenants?

Using an account that is specific to that tenant with global admin rights

Hey @Wayne,

I guess the only thing for it is a case with Microsoft to find out why their API isn’t functioning correctly with your tenant / user account.

I will do some more digging through their docs to see if I have missed something else as well.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.