Execute Workflow Trigger doesn't listen for events (gives empty output)

I guess, the main purpose of the Execute Workflow Trigger is to wait for incoming data to test the workflow. So it must work like a Webhook in the Test mode


But instead, it doesn’t wait for being called and simply gives an empty outcome. So right now it doesn’t differ from the Manual Execution Node. It’s a bug?


The input for the trigger node will only ever be the JSON that was input to the calling execute workflow node. So to test you can just copy and pin data from your calling workflow for testing.

1 Like

@pemontto I’m afraid I don’t get you. You mean “output to the calling”? Yes, that should be. But there’s no chance to get any calling output. This trigger doesn’t wait, it fires without any calling. It gives empty result.

I guess that if the button is called “Listen to event”, then it must listen to event, like a webhook does. So this is clearly a bug.

1 Like

You’re right this is a UX bug. I was providing a workaround for it. But as far as I’m aware there’s no way to call the workflow as a “test”.

The option would either need to be added to the execute node, the API, or the button changed to suggest pinning data instead of triggering immediately.

EDIT: no you can’t actually pin data, because if you hit the Listen for Event:

EDIT2: you can pin data and use it with the workflow, you don’t need to hit the “Fetch Test Event” to test the rest of the workflow


@pemontto The most simple solution for me is to add a Code node with sample date, just paste the sample output. And switch starting node for testing. A bit inconvenient though

Coming back to this, you actually can pin data and use it with the workflow, you don’t need to hit the “Fetch Test Event” to test the rest of the workflow

Then this Listening button should be renamed

Unsure if this is related, but I can’t even activate my workflow that has a Execute Workflow Trigger as the first node. Is this also a bug? Without the ability to activate this workflow, I can only click on Listen For Event to test and I’m seeing the same issue with empty input data after trigger.

Not a bug, a workflow trigger doesn’t need to be activated to be called :+1:

@pemontto Do you agree that “Listen for event” button name here is wrong?

Completely agree. Misleading/wrong. Likely not a trivial change however, I think it might be something global, and not something easily specified in the individual trigger nodes :thinking:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.