Executing workflow never stop

We install a n8n on IIS windows server. When i used it localy with http://localhost:5678 “Execute workflow” is working well. When i used it with my remote address https://n8n.my.address it start “Executing workflow” but it never stop.
I do configurate VUE_APP_URL_BASE_API and WEBHOOK_URL i get access to n8n on my remote address but no workflow starting…

Hey @michael75, welcome to the community!

This typically happens when a reverse proxy server isn’t configured quite as expected and prevents some server events from making their way to the UI (so the workflow might be stopped, but the UI doesn’t reflect it).

I don’t know how to configure IIS but you can find a few examples for other servers such as nginx here on the forum like this one:

Perhaps you could check if all IIS equivalents are configured in a similar manner?

Many thanks for your answer but this solution is not working for me.
On my set up, I put a IIS on my Windows server that do a redirection for my NDD to the localhost:5678. Then i start n8n with npx n8n. For the configuration i put:

This working well and i have my n8n on https://n8n.my.address but when i try to start a working it never stop…

Do you have any idea?

The issue was du to the Buffer setting on my IIS. I put the Response buffer threshold to 0 and it works.

1 Like

Thanks so much, glad to hear you sorted it out and thanks for sharing!