Executions are frozen in the Running status and does not change to Succeeded

After upgrading from 0.236.3 to version 1.0.5, I ran into a problem, some executions freeze the Running status and do not change to Succeeded, although the workflow was actually executed. There are no errors in the server console, here is a screenshot Recorded a video Loom in which I show that there are no business processes in the “Running” status when filtering, but there are without filtering .

How can this problem be solved?

Service Configuration in docker-compose.yml

    image: n8nio/n8n:1.0.5
    restart: always
      - ""
      - traefik.enable=true
      - traefik.http.routers.n8n.rule=Host(`${SUBDOMAIN}.${DOMAIN_NAME}`)
      - traefik.http.routers.n8n.tls=true
      - traefik.http.routers.n8n.entrypoints=websecure
      - traefik.http.routers.n8n.tls.certresolver=mytlschallenge
      - traefik.http.middlewares.n8n.headers.SSLRedirect=true
      - traefik.http.middlewares.n8n.headers.STSSeconds=315360000
      - traefik.http.middlewares.n8n.headers.browserXSSFilter=true
      - traefik.http.middlewares.n8n.headers.contentTypeNosniff=true
      - traefik.http.middlewares.n8n.headers.forceSTSHeader=true
      - traefik.http.middlewares.n8n.headers.SSLHost=${DOMAIN_NAME}
      - traefik.http.middlewares.n8n.headers.STSIncludeSubdomains=true
      - traefik.http.middlewares.n8n.headers.STSPreload=true
      - DB_TYPE=postgresdb
      - DB_POSTGRESDB_HOST=postgres
      - N8N_PROTOCOL=https
      - N8N_PORT=5678
      - NODE_ENV=production
      - N8N_SMTP_SSL=${SMTP_SSL}
      - N8N_LOG_LEVEL=debug
      - N8N_HIDE_USAGE_PAGE=true
      - postgres
      - n8n_storage:/home/node/
        condition: service_healthy

Information on your n8n setup

  • n8n version:1.0.5
  • Database (default: SQLite):PostgresSQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main):main
  • Running n8n via (Docker, npm, n8n cloud, desktop app):Docker-compose
  • Operating system:Ubuntu 20.04.6 LTS (GNU/Linux 5.4.0-42-generic x86_64)

Hi @aerostovtsev :wave: Thanks for all that information!

Out of curiosity, does this persist if you reload the executions list by refreshing the page?

1 Like

Yes, after refreshing the page and restarting the container in the docker has no effect, the status remains “Running”.

Hi @aerostovtsev , that’s odd - would you be able to share your execution data? If you don’t want to post it in the forums, you’re free to send me a DM :slight_smile: You can get that by visiting this URL, after editing it to match the details of your instance: https://n8n.example.com/rest/executions/xxxx, where the x’s are the execution ID you’re grabbing the data for.

Hi @EmeraldHerald, sent workflow data in a private message

Hi @aerostovtsev - Thanks for that, I’ll take a look and get back to you as soon as I can :slight_smile:

Just an update here for you - unfortunately I was unable to reproduce the error, but I’ve passed on all this information to our engineers who will take a closer look for you :bowing_man: I’ll be back with updates as soon as I have them!

1 Like

Hi @aerostovtsev - I have a few questions for you from the engineering team.

Does the instance crash at any point during the execution? What happens if “Save execution progress” is enabled - can we see how far the execution goes before getting stuck in this running status?

Hi @EmeraldHerald
There was no instance failure in the console, when running a single data workflow, one part was in “Running” and the other part was in “Success”.

After enabling “Save execution progress:Yes” the workflow fixed the issue, now a new one
The execution displays the correct “Success” status. I will keep watching.

Thanks for the help!

1 Like

Thanks for that, I’ve passed that on! I’ll be back with either updates or questions from the team :slight_smile:

Hi @aerostovtsev :wave: A quick update here - While they haven’t been able to find a solution for your specific case here, the developers are working on improving executions with some large changes to this area of n8n, so hopefully in an upcoming release this will be prevented from happening in the future :slight_smile:

1 Like

Hi @EmeraldHerald, thanks for the feedback! Now my instance is working fine, all the workflows that were executed are displayed with the correct status for the last 24 hours.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.