Exporting Content of PDF File for filtering

Hello there,

i’m currently trying to read the content of a PDF file which is downloaded via the Nextcloud node.

The download process is no problem, works fine. But when I try to open the PDF after the Nextcloud node, the file cannot be read. Seems like there is no content in this PDF, although there is.

The “Extract from PDF” node of course cannot read the PDF afterwards.

Do you have any recommendations for me how I can fix this?

Thanks in advance!

Greetings
Chris

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:
  • n8n version: 1.36.4
  • Database (default: SQLite): no Info
  • n8n EXECUTIONS_PROCESS setting (default: own, main): no Info
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Debian 12

Is there an error in the Nextcloud node? And have you tried downloading other PDFs from your Nextcloud?

Hey @bartv
No, the nextcloud node works well. Indeed, i tried several PDFs (self created and some that someone sent me).

Thank you
Chris

Can you see the PDF data in the nextcloud node after executing it? Could you share a screenshot? Just trying to understand the issue - is the nextcloud node returning data, but the ‘extract from file’ node is not working?

Of course.
Here are my Screenshots:




You have to view them from bottom to top.

That’s odd… Can you share the values of your Binary data environment variables?

The instance is installed via docker-compose. There’s no such value integrated, so I guess it’s using the standard variables.

Could you set N8N_DEFAULT_BINARY_DATA_MODE to filesystem then stop and start the container and try again? The default is to keep it in memory which could be the issue. We’re probably going to change that in the future.

I set the parameter to filesystem, restarted the container and the whole server. I do get the same error.
Env_Values
Is my .yml correct?

Could you check that PDF manually on your filesystem and check the filesize? 2kb is suspiciously low, we weren’t able to create test files under 6kb :thinking:

Are you sure your nextcloud is configured correctly? It might be worth checking if you’re able to list files in directories using n8n

Hey Bartv,
on my filesystem the file has a filesize of 200kb… even when I use the IMAP Node and use the attachement for further process the size is ~2kb. It looks like my N8N instance can’t process the PDF files correct.

Hey @chit4,

As a quick test could you try running the workflow below and let me know if that works.

Hey Jon,
works perfectly fine…


Hey @chit4,

Perfect, To extend it a bit can you now try the below, It is going to upload the same file to NextCloud then download it putting it in a different property and trying to read it.

Hey @Jon,

thank you for support :slight_smile:

Upload works fine, when downloading the file, the filesize shrinks from ~110kb to ~2kb again. File is not readable by the extract node.


Hey @chit4,

Just so I can try and get close to your config, Which version of Nextcloud are you running?

The issue you had with IMAP is something we were aware of and it should be fixed now so updating n8n should solve that part.

I’m using NC Version 28.0.7.