Failed to find external creds adding button

Hi everyone, I’m having some issues with some missing features in the N8N self-hosted version I’m using and was just wondering if I could get some help?

I have two versions on n8n: the cloud version and a self-hosted version that I am messing around with.

In my cloud version, when I’m adding credentials to the Google Drive node, there is a very user-friendly log-in button which redirects you to a Google Login pop-up page to handle the OAuth2 authentication and then redirects you back. This is a very simple way to connect external tools (i.e. Google Drive).

however in the self-hosted one, I’m running locally using docker, this button is not there, I was just wondering if anyone knew why this is?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @kyle_swire-thompson, this is expected I am afraid.

On n8n cloud we have registered n8n.cloud as an OAuth client with Google (and a bunch of other services as well).

When self-hosting n8n you’d be using a server outside of our control and have to register such a client yourself. The process is documented here in our docs. After going through this process you will receive both a client ID and a client secret from Google. Once you enter these details in n8n, the “Sign in with Google” button should appear on your self-hosted instance as well: