Failed to get items from DynamoDB using an index

I’m trying to get DynamoDB items using filters from a specific index and I’m getting the following error message:

ERROR: Cannot read property ‘message’ of undefined

I’m not quite sure if I’m missing something. I’m successfully inserting items with the same credentials, but still can’t get the items properly.

Information on your n8n setup

  • n8n version: 0.153.0
  • Database you’re using: PostgreSQL
  • Running n8n via [Docker, npm,, desktop app]: Docker

Hey @marcos.martinewski,
welcome to the community :tada:

I am not an experienced with DynamoDB, it looks like the error could come from here. That’s just a guess but it would apparently mean that The AWS credentials are not valid!.

If you remove your Key Condition Expression does it work then? I see that you are using retaierId = : retailerId AND status = :status. Maybe you need to remove a space to use :retailerId instead of : retailerId.

Hi, Marcus. Thanks for the reply. I tested the credentials and it is working. But I’ll try to remove that space at retailerId to see if works. I tried so many things, so I think I’m getting a little bit careless.

Yep, tried removing that space in :retailerId and didn’t work. I’ll try other things while I don’t get a solution.