Flow Never Completes

Describe the problem/error/question

I have an unusual issue with one of my flows. It seems to never stop. I’ve never had any issues like this before and when I run the same data through in a test it does complete. But on production call it gets to the if node and just hangs there, every time.

Unfortunately I can share the entire flow since there are needed but these are the last steps and it there is nothing that should be causing it to fail. I even put a 5 min timeout on it and it was running for over 800 minutes before I noticed and canceled it.

I’m not sure if the test data output will show in the example of the call workflow node, but below is its output.

[
    {
        "errors": [],
        "success": true,
        "Message": "Files successfully uploaded.",
        "Successes": [
            {
                "litify_docs__Version_Id__c": "TgpWi2J6p76_SsTEMLnH.lR5X6y3NTMl",
                "litify_docs__Source__c": "Docrio Api",
                "litify_docs__File_Size__c": 51643,
                "litify_docs__Has_Attachments_Legacy__c": false,
                "litify_docs__Updated_By_Name__c": "Philip Wiggins",
                "litify_docs__Delete__c": false,
                "litify_docs__Updated_On__c": "2023-12-12T01:01:42.815Z",
                "litify_docs__Updated_By__c": "00546000001pssAAAQ",
                "litify_docs__Folder_Path_Last_255__c": "[]",
                "litify_docs__Folder_Path_First_255__c": "[]",
                "litify_docs__Latest_Version_Formula__c": 0,
                "litify_docs__Folder_Path__c": "[]",
                "litify_docs__OCR_Compatible__c": true,
                "litify_docs__Latest_Version__c": 0,
                "litify_docs__Related_To__c": "a0I8Z00000Mg4nMUAR",
                "litify_docs__Related_To_Api_Name__c": "litify_pm__Matter__c",
                "litify_docs__File_Type__c": "application/pdf",
                "litify_docs__File_Link__c": "/lightning/r/litify_docs__File_Info__c/a2W8Z000014NjWL/view",
                "litify_docs__Complete__c": true,
                "SystemModstamp": "2023-12-12T01:01:37.000Z",
                "LastModifiedById": "00546000001pssAAAQ",
                "LastModifiedDate": "2023-12-12T01:01:37.000Z",
                "CreatedById": "00546000001pssAAAQ",
                "CreatedDate": "2023-12-12T01:01:37.000Z",
                "Name": "Test, Betty - Questionnaire.pdf",
                "IsDeleted": false,
                "OwnerId": "00546000001pssAAAQ",
                "Id": "a2W8Z000014NjWLUA0"
            }
        ],
        "Failures": [],
        "sfToken": "redacted",
        "litify_docs__Related_To__c": "a0I8Z00000Mg4nMUAR"
    }
]

Information on your n8n setup

  • n8n version: 1.20.00
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via CLOUD

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Also. This is doing nothing. I have test running past 5 min now and its set to timeout after 2 min.

Hey @Philip_Wiggins,

Sadly I would need to see more of the workflow and the data to work out what is going on.

Not sure how much it will help since there are some creditials required for some of the node, but nothing i’ve tried makes this complete. When I stop the execution the flow has finished and the last node has run, but n8n never shows the flow is complete.

The credentials side doesn’t really matter this lets us see the nodes you are using and get a feel for what you are doing. How many iteams does this workflow typically work with and what is the subworkflow doing?

In your original post you mentioned that it hangs on the If node is that in the execution log that you are seeing that or does it just look like it is stuck on the if node because there is pinned data in the sub workflow?

It is important to know that the workflow timeout only kicks in when a node finishes so there is a change that your workflow is getting stuck on one of the nodes.

Its always whatever the last node is. It says its rand the Do nothing Node. When I stopped the execution of this one It says it hit the last node, but as you can see below it was running for hours on that node.

Screenshot 2023-12-15 at 7.11.13 AM

What is the username for your cloud instance?

[email protected]

FYI I have another one thats doing the same thing now and older flow that wasn’t having this issue prior. It seems to be ones with webhooks. It won’t let me paste it here it says its to many character for the body.

The tests I did was with webhooks as well but I am unable to reproduce it so I suspect there is something specific to your cloud instance so I will need to escalate this to the cloud team to look into.

Ok. Its really wierd because all of the nodes do what they need to in the background. I’ve confirmed that the data that the last node should be applying is working and doing what it should, it just never confirms complete.

This is now with our Cloud team, I will let you know when they reply.

1 Like