Flows do not start automatically

Hello,
Although my automatically started flows with cron have been active for 6 months, they have not been working automatically for the last 3 days.
When I click Execute Workflow it works fine.

HI @emretekin :wave: Welcome to the community :tada:

Can you share what your workflow looks like and how you’re trying to schedule? Also, are you using n8n cloud or self-hosting? If self-hosting, have you made any changes to your setup?

Could you also share the following:

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

I am using N8N Cloud. The entire workflow was working smoothly until the last week.

I’m adding one of the workflows that doesn’t work below. It runs when I only click Execute Workflow.

Hi @emretekin - by those screenshots, you’re on a very old version of n8n. Could you please try upgrading through your admin panel on cloud and seeing if the issue still persists? While you’re there, it would also be a smart idea to double check your timezone settings :bowing_man:

If it still happens, could you try replacing the old Cron trigger node with the new Schedule trigger node? :+1:

1 Like

Thank you very much, upgrading worked. :+1:

2 Likes