Flows not visible after upgrade to 1.0.5 (help!)

Describe the problem/error/question

I’ve recently updated my docker container to the latest version (1.0.5 according to the settings page) of n8n. I notices today that I did not receive any messages anymore so I logged in to n8n and discovered that I needed to setup an account (I already had one).

After completing the steps I now have a n8n install without my workflows… Where did my workflow go to? I do see them in the SQLite table.

Funny detail… normally when I start my container I see all workflows being scheduled, or how this is called, but when I start n8n now I don’t see them anymore on the CLI.

Any idea how to see / reactivate my workflows?! All past upgrades when very smooth, but this one is really annoying :frowning:

What is the error message (if any)?


Information on your n8n setup

This is displayed on the CLI:

UserSettings were generated and saved to: /root/.n8n/config
n8n ready on, port 5678
Migrations in progress, please do NOT stop the process.
query is slow: COMMIT
execution time: 1107
query is slow: COMMIT
execution time: 1939
query is slow: COMMIT
execution time: 1080
query is slow: INSERT INTO "migrations"("timestamp", "name") VALUES (1673268682475, ?) -- PARAMETERS: ["DeleteExecutionsWithWorkflows1673268682475"]
execution time: 1226
query is slow: COMMIT
execution time: 1055
query is slow: COMMIT
execution time: 1555
Pruning was requested, but was not enabled
Initializing n8n process
query is slow: VACUUM;
execution time: 1034
query is slow: COMMIT
execution time: 2421
Version: 1.0.5
query is slow: DELETE FROM "webhook_entity"
execution time: 1758

Editor is now accessible via:

Press "o" to open in Browser.
query is slow: COMMIT
execution time: 1467
Owner was set up successfully
query is slow: UPDATE "settings" SET "value" = ? WHERE "key" = ? -- PARAMETERS: ["true","userManagement.isInstanceOwnerSetUp"]
execution time: 1003
User survey updated successfully

  • n8n version: 1.0.5
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Synology

Hi @jicho, I am sorry you are having trouble.

Unfortunately I don’t have a Synology system and don’t know how one would deploy n8n on it.

Is there a chance you were using a custom n8n image in your docker setup? I am asking because your n8n instance seems to run as the root user based on the UserSettings were generated and saved to: /root/.n8n/config line. The standard n8n image would run as user node though (and has been for quite some time, even on previous versions).

If so, you might need to update the configuration in your system, similar to what has been described here. If that’s not it, can you confirm which command/docker compose config exactly you are using to run n8n and where your SQLite database with the workflows lives?

Can you also confirm from which version you have upgraded?

Hi @MutedJam ,

A long time ago I followed the following command and did something like this on my Synology CLI:

docker run -it --rm \
	--name n8n \
	-p 5678:5678 \
	-v /volume1/docker/n8n:/home/node/.n8n \

For updates I do a recreate in combination with re-pull image in Portainer (i.v.m. installed Portainer a long time after I’ve installed n8n).

Your remark about the config that was stored in /root/.n8n/config triggered something since I map it to a complete other folder… As a result I’ve logged in into the container and, as the log said saw that /root contained the config and I couldn’t find .n8n in /home/node.

After deleting my current container/config and running:

sudo docker run -d \
    --name n8n \
    --restart=always \
    -p 5678:5678 \
    -v /volume1/docker/n8n:/home/node/.n8n \

Everything is working again! As it turned out it looks like, for some reason, the volume mapping did something weird after upgrading…

As it seems the problem is solved!

Thanks for your reaction and pointing me in the direction that solved the problem as I can see my workflows again, yeah!


Amazing, glad to hear this is sorted! Thanks so much for confirming :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.