Format for Headers in with HTTP PUT and RAW data (Header parameters as JSON or RAW)

I am trying to PUT data to Azure filestore - and it requires a header “x-ms-blob-type”.

For the life of me I can not work out the correct format for “Header parameters as JSON or RAW”. I have tried:
x-ms-blob-type BlockBlob
x-ms-blob-type: BlockBlob
{x-ms-blob-type: “BlockBlob”}
{“x-ms-blob-type”: “BlockBlob”}

and in all cases I get an error like this:

This does work if I set the headers in the UI with “Send Binary Data” off - but I need to send that data up…

Any help/ideas/points as to how to add this header correctly would be appreciated.

Cheers,

Jake

Try this if it works :slight_smile:

Thanks - I am afraid I dont get this option in the UI as RAW is set - the example shows:
image
But I see:
image

What I have set though is this - so we will see if it works…

{
“name”: “x-ms-blob-type”,
“value”: “BlockBlob”
}

Did you tried this?

{
“name”: “Content-Type”,
“value”: “x-ms-blob-type”
}

Yes - I have now tried what I mentioned above - as well as this - resulting in this error:

I dont think this one would have worked regardless, as I need to set the header x-ms-blob-type to be the value of BlockBlob - not the content-type.

Hey @jakevis, this is unfortunately the expected behaviour with the HTTP Request node and it has confused me too :frowning:

You’d need to return a JSON object in the headers field using an expression rather than write a JSON string. This earlier post of mine has an example of how such an expression could look like, in your case the expression should be something like {{ {"x-ms-blob-type": "BlockBlob"} }}:

This is the resulting header:

image

1 Like

Thank you!! That fixed it for me
image

Works a charm!