Get item by column value on Monday producing an error

Describe the issue/error/question

When using the Get Item by Column Value on the Monday Node I get an error when I use a value from the previouse node and the Monday column to look in is not the first column (Name from the column pull down list).
If I write the value directly as fixed or in the expresion box then I can search on other columns just fine.
To test this I created an item on monday with the same info (1915) on 3 columns. The main or first column (username), a number column (Id) and a text column. Then on the Monday Node I changed the target column to each of this columns with the column value being first fixed and then with the column value being extracted from the node’s input data. When the column was first column from the drop-down it worked fine with for fixed and dynamic values. When the column was not the first column then it only worked when the data was fixed and produced the error when the data was extracted from the nodes input data.
I am pasting screenshots to show what I did.

I hope I have been clear in my description.

What is the error message (if any)?

Cannot read properties of undefined (reading ‘items_by_column_values’)

Please share the workflow

Information on your n8n setup

  • n8n version: Trial Period.
  • Database you’re using (default: Postgres):
  • Running n8n with the execution process [own(default), main]:
  • **Running n8n via

This sounds like a bug to me, seeing the node tries to read a non-existent property :frowning:

Perhaps @Jon can take a look into this one?

Thanks @MutedJam. Hope @Jon can take a look. I don’t like the work around I had to use.