Get running time entry from toggl ( HTTP Request Node, GET, curl )


I’m trying to get running time entry from toggl via HTTP Request Node (GET, curl) :

curl -v -u 407a84:api_token \ -X POST

It is written in the documentation:


I’m trying to use the information that was pointed out to me in this thread as a basis.

But unfortunately if you switch to GET there is no option of body field.

I tried entering the query in Headers, Query Parameters and other different things, but unfortunately there is no result.

How do I make this thing work?

Thank you very much!

Information on your n8n setup

  • n8n version: 0.183.0
  • Database you’re using: SQLite
  • Running n8n via: Docker

Hey @Mikhail,

The CURL request you have posted isn’t sending any body data so it wouldn’t be needed. It looks like what you have should do the job and you won’t need to toggle that JSON/RAW option so that can be disabled.

1 Like

Hey @Jon! Thank you so much for responding so quickly! Yes, it worked! :muscle: :handshake:

curl -v -u 407a84:api_token \ -X POST

Unfortunately, I am not an IT specialist.
That’s why I bother with all sorts of things.
At least it will be easier for others like me to figure it out later!

1 Like

Hey @Mikhail,

No worries, I am wondering if maybe we need a Toggl node rather than just a trigger :thinking:

1 Like

If it can be done quickly, I think it’s worth doing, since a lot of people work with it.