Getting 403 Errors in Xero node, but only when "return all" is checked?

Describe the issue/error/question

I’m getting a 403 error, but it doesn’t appear to be related to my credentials. When I have the “load all records” box checked in the Xero list node, it returns a 403, but if I just load 100 records, the authentication works perfectly fine.

Anyone have any insight as to whether this could be a bug? Problem on Xero’s end? Bad error message? A problem located somewhere between my chair and keyboard?

This has worked previously, but stopped recently. To be honest, I’m not entirely sure when it stopped working because I wasn’t monitoring it close enough, but this leads my to my next question-- is it safe to downgrade to a previous version? This may coincide with my recent update to 0.171.0, I’ll need to figure out what my pervious version I was on but if someone can confirm that just running a previous version of N8N in docker won’t mess up my automations and everything, I’ll downgrade and give it a shot which would confirm if the problem was introduced with the update.

What is the error message (if any)?

ERROR: Forbidden - perhaps check your credentials?
403 - {“Type”:null,“Title”:“Forbidden”,“Status”:403,“Detail”:“AuthenticationUnsuccessful”,“Instance”:“1e484ee5-b2c6-49c0-b6af-95e7f2f3f914”,“Extensions”:{}}

Please share the workflow

Information on your n8n setup

  • n8n version: 0.171.0
  • Database you’re using (default: SQLite): default
  • Running n8n with the execution process [own(default), main]: default
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hi @scottthesecond, welcome to the community :tada:

I am so sorry to hear you’re having trouble here. From giving this a quick go on my end I could confirm the problem and shall add it to our internal bug tracker.

It failed for me until a few minutes ago and just when I was talking to @Nivb_6 about the error it started to work again for me. So I wonder if this might indeed have been a temporary problem on Xero’s end. Would you be able to re-test this on your end (and double-check you’re using a valid Organization ID)?

Thank you! Appreciate that you follow the forum and that you got back to me so quickly!

I did try again just now and am still seeing the same problem. Though, I wouldn’t put it past Xero to have an intermittent bug like this.

As for the organization, I am selecting the organization from the list in the node, and since it’s working correctly when I uncheck the “load all” option I have to assume the organization is valid or it wouldn’t work at all, right?

In the meantime, I thought I would also be able to achieve my goal by paginating, but I don’t see any way to specify a page number or offset in the Node. Is that correct or am I missing something?

As a side note, sorry that my first post is a request for help! I’m new to N8N but we think it’s a great product and I’m excited to learn more.