[Github] Token is not valid: undefined

I’m getting the following error when trying to integrate with Github

I have noticed that the personal access tokens now seem to be prefixed with ghp_ whereas the old ones did not.

Any idea how to resolve this?

Hey @RedPacketSec, thanks very much for reaching out! I encountered the same error and I suspect the credentials validity check is either broken or uses a method not allowed with your token.

The token itself should however still work (assuming it’s valid). Could you try saving your credentials regardless of the error and confirm whether the GitHub node works for you?

didnt work, had to move over to oauth which is ok for now but not ideal

Hm, I am afraid I am not able to reproduce the problem in this case (as token auth is still working fine for me when ignoring the validation message). I’ll add this part to our bug tracker for a closer look, but if your token is not valid at all (meaning you’re also unable to use the GitHub node) this is most likely a problem with your token rather than n8n.

brand new token from github, copied and pasted directly in, no whitespace etc.

Same here, the token is working as expected I am afraid. Which action exactly are you performing in your GitHub node that doesn’t work with your token? Can you share an example workflow?

just 2 simple delete and create files.

but I’ve moved over to oauth for now and I just need to get some stuff done instead of troubleshooting.

Thanks, just report back when you have an example ready to test :slight_smile:

I got same problem.
My configuration in github

And here is the problem

Hey @QuocTan,

The token will still work in a workflow, I tested this yesterday with 3 tokens. The good news is we found what the issue is as well so will get it fixed soon.


Got released with [email protected]

1 Like

Thanks, it worked :grinning: