Gitlab error response [404]: 404 Project Not Found

I am using gitlab trigger and i create personal access token for the credentials.
When i run i get Gitlab error response [404]: 404 Project Not Found
My repository i private in Gitlab and i am a member of it and not the owner but i am giving the name of owner and project name

Welcome to the community @Wahdat_Jan!

Sadly think I am not able to help you here. The issue is not n8n related it is with Gitlab as all that n8n does is to call their API. I tried to find some information online but had sadly no luck. Also, do I have to confess that I have no experience at all with Gitlab in general. So the only advice I can give you is to see if there is some higher “level” then just “member”. It is possible that you have to be “admin” or similar to be able to set up a webhook. And if also that does not work your best bet would probably be to post on a Gitlab community forum for that very specific problem. Very sorry!

1 Like

it seems i have to add tokens of the owner not member.

1 Like

Ah great that you found the solution. Thanks a lot for updating here. I am sure will be helpful for other people in the future.

1 Like

I’ve tried your solution as well. Didn’t work.

@b4oshany I don’t know if it will help you, but I just was struggling with this same issue and figured it out. For me, my repo is a company repo instead of a personal one, so the ‘Repository Owner’ value was not my username but the string after the in the URL