Google Drive - Execute Workflow Trigger - Test shows different results vs triggered

I have a simple workflow calling the Google Drive search function passing in { “query”: “text” }. I have it pinned within the “Execute Workflow Trigger”.

When I test the workflow from the editor, it returns the results I expected, which are 47 items that are documents and PDFs.
Editor Trigger Image:

When I run this from another workflow, showing it here, I can see that it is returning JPEG, PNG, and JavaScript files. I have Return All enabled, and I only see 11 items.

What is the error message (if any)?

I’m not getting any error messages from Google Drive

Please share your workflow

Share the output returned by the last node

The output is coming in the correct format, I’m just getting unexpected results.

Information on your n8n setup

  • n8n version: 1.47.1 - Docker Image: latest
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Execution order: v1 - not sure on the Executions_process
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker n8n single instance
  • Operating system:. running on Synology NAS

I’m facing same problem here. Test shows a different result and my process don’t work.

I upgreaded to version 1.47.3, still having the issue with data not running in production as expected.

1 Like

I upgraded to 1.48.3 and it did NOT fix the problem.

I upgraded to version 1.49.0, and the problem persists. Going to report this as a bug: Google Drive - Bug in Search Operations when called by Execute Workflow · Issue #10041 · n8n-io/n8n · GitHub

Hey @DavidMONeil,

Looking at your screenshots the query being passed to the node and the expression are different, Did you try {{ $json.query.query }} which looks to be the value set in the node before it?

Jon,

Thanks for pointing out the obvious thing I was 100% not seeing.

So I got the results I had anticipated when I went into the Trigger node and removed the Define Output. which I was passing { ‘query’ : ‘string’ }. For some reason, it was passing my defined inputSchema inside another query string.

I just removed the required input → by unchecking this.
image

I appreciate your time, and I will now investigate the proper use of the Specifcy Input Schema with AI Tool Agents.

Dave

1 Like