Google Drive node not working

Hello N8N Community!
I am once again faced with a dilemma waiting to be solved by the wonderful helpful people we have here :smiley:

The Google Drive node doesnt seem to work even after setting up.
I intend to list the contents either in the Drive or a particular folder, but I am not able to do anything.
Please help!

Hey @Dhyaneshwar_Ra,

When you say it isn’t working what do you mean? Do you get any error messages? What operations are you trying?

I am trying to execute the node, and list the files in a particular folder, where I want to use the query string and get a particular file that matches a string.
I am not able to list the files if I choose the operation as β€˜List’

Any error message and is it a shared / team drive or a normal user drive?

It says executed successfully but but does not show any thing in output. Also it is a normal user drive

Are you using a service account or oauth credentials?

I am using service account. I have enabled the relevant APIs also

Does the service account have access to the users drive? Did you do the domain wide delegation stuff for it?

it is a personal drive, I dont have any domain associated with it tho

Maybe using a service account is a bit over the top, try oauth.


OMG It worked!!!
Thank you so so so much!


Happy automating :+1::tada: