Google Sheet 400 Error - Unable to parse range

Edit: :white_check_mark: Updating to version 0.84.4 will fix this issue.

Me and @mskian Facing the same issue after updating to version 0.84.3
Using via Docker

  • Tried Reauthenticating the Google API
  • Tried with Different Sheet

still the same…

ERROR: 400 - {"error":{"code":400,"message":"Unable to parse range: A:D1:undefined1","status":"INVALID_ARGUMENT"}}

StatusCodeError: 400 - {"error":{"code":400,"message":"Unable to parse range: A:D1:undefined1","status":"INVALID_ARGUMENT"}}
    at new StatusCodeError (/usr/local/lib/node_modules/n8n/node_modules/request-promise-core/lib/errors.js:32:15)
    at (/usr/local/lib/node_modules/n8n/node_modules/request-promise-core/lib/plumbing.js:104:33)
    at Request.RP$callback [as _callback] (/usr/local/lib/node_modules/n8n/node_modules/request-promise-core/lib/plumbing.js:46:31)
    at Request.self.callback (/usr/local/lib/node_modules/n8n/node_modules/request/request.js:185:22)
    at Request.emit (events.js:310:20)
    at Request.<anonymous> (/usr/local/lib/node_modules/n8n/node_modules/request/request.js:1154:10)
    at Request.emit (events.js:310:20)
    at IncomingMessage.<anonymous> (/usr/local/lib/node_modules/n8n/node_modules/request/request.js:1076:12)
    at Object.onceWrapper (events.js:416:28)
    at IncomingMessage.emit (events.js:322:22)

Hi @mcnaveen, I am unable to replicate this error. Can you please provide more information such as your workflow and/or the configuration of the Google Sheets node?

From a first glance it seems like the value in the Range field is incorrect.

Case in point, here’s me reading data using the Google Sheets node.

As soon as I enter the Range incorrectly (see the Range field), I get the same error as mentioned above.

Hope that helps!

Reading works fine for me too bro. But Append having issue. Please check with that once again.

Here is the screenshot from @mskian. We both getting same error. No difference.

We never tried to edit range manually while workflow is active or didn’t even touch Google Sheets.

All this happening after updating to latest version of n8n. @jan

Insteresting @mcnaveen.

@jan I’m actually getting the same error when trying to append data into Google Sheets.

1 Like

Yes, there was apparently a bug in the latest version. @RicardoE105 fixed it already in the meantime.

A new version with the fix just got released as [email protected]

Can you please retry with that version. Thanks!


Updating to version 0.84.4 will fix this issue.

:pray: Thanks @jan @RicardoE105 @tanay for quick action.

It’s time for me to go back to sleep. It’s 2 AM and woke up by this Notification. Take Care guys.

Thanks for confirming but did not want to ring you out of bed for that :wink:

Good night!

1 Like

Ah it’s ok bro. Good Night :sleeping:

Thanks for making my life easier. :pray:

1 Like