Google sheet trigger stopped working, 503 error

Describe the problem/error/question

A workflow was working fine, then started crashing with the following error on the google sheet trigger node on “row added”. Possibly this started happening after updating to n8n Version 1.25.1, but not sure.

Please advise what could be the problem, it was working fine for a long time and I’m not hitting any limits or anything

What is the error message (if any)?

503 - {“error”:{“code”:503,“message”:“The service is currently unavailable.”,“status”:“UNAVAILABLE”}} - The service is currently unavailable.

Please share your workflow

Information on your n8n setup

  • n8n version: 1.25.1
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: l Ubuntu 20.04.6 LTS (GNU/Linux 5.4.0-170-generic x86_64)

Hi @PvUtrix :wave: A 503 would still indicate a server error of some sort :thinking: Have any of the credentials changed, or possibly how are you running n8n with Docker? Would you happen to be using a reverse proxy?

The weird thing is that if I execute the workflow directly, it’s working fine, the google sheet trigger node gets all the results

but it’s always failing, yet showing “status unkown” if executed by a real update of the google sheet

Hi @PvUtrix :wave: Thanks for going into those details!

I’m still not able to reproduce this, could you perhaps share your Docker compose file (and please don’t share any passwords)?

It’s pretty much default. I’ve upgraded to 1.26 let’s see if that makes any difference

That looks like the default setup, @PvUtrix - as a 5xx error would be a server error from Google, I’m not too sure what’s happening here. How many items are in the sheet? Does it happen with all sheets, or only this one?

not many, I’ve checked another flow with just 17 items in the google sheet. If executed manually, it works

Also another strange thing, the scheduler was set to every minute, but as you can see it was trying 4 times a day, with minute intervals and failing all of them with the same error as I have mentioned above

Hey @PvUtrix,

The execution log will only show a run if there is an error or if there is data being fetched from the sheets revision history.

Manually triggering the workflow does do things a little bit differently in terms of how much it fetchs but other than that it is mostly the same.

As mentioned above the 503 error you are seeing is likely to be coming back from Google it will just be a case of working out what they are not happy with.

If you go to Metrics in the Google Developer console does it show the errors as that could help to work out where it is going wrong.


Thanks for helping out Jon. It seems errors have appeared recently, I will try to dig further about their root cause.

30 days, 0% errors

1 day, 13%!

I’ve recently faced the 503 error more often than before. I don’t know what happens to n8n or Google Sheets API.

Hey @dongphuchaitrieu,

If you are interested you can find more on what the 503 error means here: 503 Service Unavailable - HTTP | MDN

It is odd for Google to return it though so I expect it is some kind of limiting they are doing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.