Google Sheets Error - Range ('XX'!XX) exceeds grid limits

Describe the problem/error/question

Hey guys!

This morning I’m having problems with the Google Sheets node when inserting new data into a spreadsheet. Something that had always worked perfectly.

I have tried from different instances of n8n and I always get the same error.

What is the error message (if any)?

Problem in node ‘Google Sheets‘
Range (‘L19’!L19) exceeds grid limits.

Please share your workflow

Here is a simple flow to reproduce the error:

Share the output returned by the last node

NodeApiError: Range ('L19'!L19) exceeds grid limits. Max rows: 1008, max columns: 6
    at Object.apiRequest (/app/code/node_modules/n8n-nodes-base/nodes/Google/Sheet/v2/transport/index.ts:72:9)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at GoogleSheet.getData (/app/code/node_modules/n8n-nodes-base/nodes/Google/Sheet/v2/helpers/GoogleSheet.ts:86:20)
    at GoogleSheet.appendData (/app/code/node_modules/n8n-nodes-base/nodes/Google/Sheet/v2/helpers/GoogleSheet.ts:264:7)
    at Object.execute (/app/code/node_modules/n8n-nodes-base/nodes/Google/Sheet/v2/actions/sheet/append.operation.ts:226:2)
    at Object.router (/app/code/node_modules/n8n-nodes-base/nodes/Google/Sheet/v2/actions/router.ts:53:9)
    at Workflow.runNode (/app/code/node_modules/n8n-workflow/src/Workflow.ts:1269:19)
    at /app/code/node_modules/n8n-core/src/WorkflowExecute.ts:952:29

In the Google Cloud Console, the Google Sheets api shows the following errors:

Is there something I am missing?

Information on your n8n setup

  • n8n version: 0.232.0 and 0.229.0
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu 22.04.1 LTS and Ubuntu 20.04.2 LTS respectively

Hi @martinhache - sorry to hear you’re having trouble with this!

I’ve copied your data exactly with your example workflow (and sheet), and I didn’t run into that error - but did have issues importing data over until I had removed and replaced some characters. Specifically, changing over to “Telefono” and “Fecha y Hora” and replacing both the accented character and the slash. This imported the data correctly for me:

I’m not sure if it’s related, but can you give that a try like in this example workflow and see if that fixes it for you?

Hey @EmeraldHerald

Thanks for your reply and for taking a few minutes to try to solve the problem.

I just tried the settings you made in the workflow, and after several tests, I think the error occurs when the name of the spreadsheet tab is changed.

As long as the various tabs keep the default name, the workflow imports the data correctly into Google Sheets (even with the special characters you have removed). But as soon as I change the tab name, the error appears again.

Can you check this point in your test workflow?

Just to rule out a bug in the Google Sheets API itself, as this is something that has never happened until today. I use the Google Sheets node on a daily basis in multiple workflows and I have it very tested.

Thanks for your time!

1 Like

Thanks for getting back so quickly, @martinhache!

I tried that out by changing the worksheet name a few times, but I was still successfully able to use the workflow I posted to send data to the sheet with no error :thinking: Just in case, I’ve tested this out on 0.229.0, 0.232.0 (both through Docker), and 0.230.3 (through cloud). The workflow executed successfully in every version and correctly appended to a sheet with a name that was changed.

As a test, can you try with a HTTP request node to the Google API and see if you can successfully add any data to the sheet? I’m curious if this would persist outside of the node, too.

Hey @EmeraldHerald

Thanks for running the checks on your workflow. I have done several tests and the behavior is somewhat erratic. It has given the same failure several times and now it works fine.

I also noticed today that the files in my Google Drive account take a while to save changes, so I gather that Mr Google is “doing” something with my account.

I will wait until Monday to see if everything has stabilized again.

Once again, thanks for your help.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.