Google sheets, list of documents does not appear

Describe the problem/error/question

From n8n, I have established a connection with Google Sheets successful. However, when choosing the sheet to work with from ‘From List,’ an error message appeared: ‘Could not load list. Please add your credentials.’
Also when I create a sheet using the same credential with the node Google Sheets/Create a sheet, it works perfectly.
Do you see the problem? Thank you for your help.


What is the error message (if any)?

Could not load list. Please add your credentials.

Please share your workflow

{
“meta”: {
“instanceId”: “dd5a6a13364f1c337c7cf1fcf4a8dfc036bea00a0fc07202e8e23dedb7406fe4”
},
“nodes”: [
{
“parameters”: {
“operation”: “append”,
“documentId”: {
“__rl”: true,
“mode”: “list”,
“value”: “”
},
“sheetName”: {
“__rl”: true,
“mode”: “list”,
“value”: “”
}
},
“id”: “aca83596-a956-4bd5-8de6-b1493531917f”,
“name”: “Google Sheets”,
“type”: “n8n-nodes-base.googleSheets”,
“typeVersion”: 4,
“position”: [
400,
300
],
“credentials”: {
“googleSheetsOAuth2Api”: {
“id”: “vxGCwUv63CrQAJL8”,
“name”: “Google Sheets account”
}
}
}
],
“connections”: {}
}

Share the output returned by the last node

Information on your n8n setup

  • version:1.1.1
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system:Linux

Hey @Minh,

Welcome to the community :raised_hands:

Normally if nothing shows in the list it means that the Google API project doesn’t have Google Drive enabled as well, can you double check the enabled APIs on the Google side?

1 Like

Hey Jon,

Magic, it works! Thank you very much.
I am new with n8n. Very happy with your fast reply.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.