Google Sheets Oauth "Access Blocked" Error

google oauth connection problem due to a problem when placing my Authorized redirect URIs

To give context, I am using the Self-Hosted version of n8n at the latest version. I am using this to connect for Google Sheet.

Thanks for the Help, i TRIED SEARCHING THE OTHER FORUMS, but I didnt see smth related to this…if there was, then sorry.
The Error is:

Invalid Redirect: must end with a public top-level domain (such as .com or .org). Invalid Redirect: must use a domain that is a valid top private domain.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Onganne, I am sorry you are having trouble.

This is not an n8n problem but a restriction put in place by Google. Google simply doesn’t accept an IP of 172.17.128.1 as the redirect destination.

Seeing this appears to be a docker IP, is there a chance you are running n8n on the machine you are trying to authenticate with? I am asking because Google would accept http://localhost:5678 instead, in case you have your n8n instance running locally and can access n8n through this:

If that’s not it you would have to set up a public domain name for your n8n instance (and make sure to let n8n know by setting the WEBHOOK_URL environment variable).