Google Sheets OAuth "Access Invalid"

Hey, whenever I try to add a new Google Sheets credentials, Googles log in screen pops up but says “Access blocked: This app’s request is invalid” instead of letting me log in.
Any thoughts on how to be able to log into Google Sheets so I can connect it to my workflow?

Hi @Stiehla,
I just tried it out with [email protected] and it worked for me.

  • Which version of n8n are you using?
  • Are you self-hosting n8n or do you use or the desktop app?
  • Did you follow the Google OAuth2 credential instructions?

In google cloud console you also have to set the right redirect URIs or you will receive an error This app’s request is invalid.

You have to copy the url from your google sheets credentials:

1 Like

Thanks for the response.
I am using self-hosting n8n. I also don’t have the option to use the “Sharing” section when making this connection. Any other suggestions for connecting to Google accounts?

Below is what I see when I try to connect.

Hi @Stiehla,

looking at your screenshot of your Google Sheets account 19 credentials I can see that it does not show any settings for Client ID or Client Secret.

  1. Are you by any chance using the environment variable CREDENTIALS_OVERWRITE_DATA or CREDENTIALS_OVERWRITE_ENDPOINT to create your google credentials?
  2. Which version of n8n are you using?

The Sharing option should not have an effect here, it allows sharing your credentials with other users on your n8n instance but is only available on for now.

1 Like

I honestly have no idea what CREDENTIALS_OVERWRITE_DATA or CREDENTIALS_OVERWRITE_ENDPOINT are. Even if I had those it doesnt seem to give an option to input them. Just a “Sign in with Google” option that gives me an “Access blocked” popup.

I believe I am on Version 0.198.2

Thanks :slight_smile:

Hi @Stiehla,

looking at your screenshot again I can see Error 400: redirect_uri_mismatch, which means you need to add Authorized redirect URIs in google cloud console as previously mentioned.

I also tried out connecting from 0.198.2 and it worked for me. When opening your google sheets credentials you should see the following properties including the OAuth Redirect URL that you need to copy to the google cloud console. Are you seeing these?

Did you follow the Google OAuth2 credential instructions ?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.