Google Sheets OAuth error

I have created and updated my Google Sheets credentianls, but they are not accepted. n8n enters a loop of demanding to reconnect or connect to Google to accept the credentials, but even if I make the operation it never validates them.

  • **n8n version: Desktop 0.209.4 (the last I can install)
  • **Database you’re using (default: SQLite):SQLite
  • Running n8n with the execution process [own(default), main]:
  • **Running n8n via [Docker, npm,, desktop app]:Desktop

Hi @Loprw_de_Mileto, I am sorry you’re having trouble.

I just tried connecting the n8n desktop app with Google via OAuth2 but didn’t run into any trouble here. After running through the OAuth flow I end up on this page:

n8n does not reflect the success immediately when using the desktop app, but after closing the credentials screen and re-opening I can see the success state in the app as well:

Seeing you are seeing an endless loop, could you perhaps try running through the process in another browser or clear your browser cache/cookies before retrying?

Hello @MutedJam
I have the same issue. I tried Safari and Chrome but cannot finish. Indeed I can see the success state but it still doesn’t work using the credentials in any workflow, being prompted to check credentials.

Hi @Cristi_Milea, are you able to manually provide a sheet ID (or URL) instead of using the list? Like so:

Yes, using document by URL works for me, I am able to select then Sheet from list.

How did you authenticate with Google and which version of n8n are you running? Are you also encountering this problem when using fresh OAuth2 credentials for Google Sheets on the current version 0.217.2 of n8n?

I am using v1.9.0 desktop, just created the credentials and wanted to use them. The app opens the login in the browser but after successful login, nothing happens back in the desktop app.

This is expected @Cristi_Milea, the authentication would take place in the browser but the browser wouldn’t redirect you back into the desktop app after the authentication.

If you check out my above post you can see I had to close and re-open the credentials screen in n8n desktop as well to see the updated status.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.