Google Sheets row update problem

version 1.18

now i can update GS row, but i need to update only one column. if i leave rest columns empty it will delete those columns which is not nice. how can i fix it?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

i fixed this by reading rows and then copying data for upadte but it should be fixed

1 Like

Hi @Edmunds_Priede, you can achieve this behaviour by using Map Automatically as the “Mapping Column Mode”:

With this setting, n8n will only overwrite the columns it actually finds. For example with a sheet like this:

image

And a node like this:

Only the “Second column” in my example sheet would be overwritten, leading to this result:

image

1 Like