Gpt-4 node error

Describe the problem/error/question

i have a ChatGPT node and want to use the gpt-4 model, which is available in my account. but it returns the error that the resource requested cannot be found.

When I use text-davinci-003 it works fine.

What is the error message (if any)?

NodeApiError: The resource you are requesting could not be found
    at RoutingNode.runNode (/Applications/n8n.app/Contents/Resources/app/node_modules/n8n-workflow/src/RoutingNode.ts:220:11)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at Workflow.runNode (/Applications/n8n.app/Contents/Resources/app/node_modules/n8n-workflow/src/Workflow.ts:1341:11)
    at /Applications/n8n.app/Contents/Resources/app/node_modules/n8n-core/src/WorkflowExecute.ts:938:29

Information on your n8n setup

  • **n8n version: 1.10.0 **
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own):
  • Running n8n via (desktop app):
  • Operating system: macOs 13.5

Hi @pehaem :wave: Welcome to the community :tada:

I was able use the gpt-4 model just there in my testing on 1.8.2 - can you try using something like Postman or Insomnia to make the call and ensure that your API token has been granted access to gpt-4?

If you can successfully make a request outside of n8n, can you try updating n8n to the most recent version, remove and re-add the open ai nodes to ensure you have the newest version of the node, and possibly also reconnect your credentials? That might fix this up.

I just saw that n8n desktop got discontinued, just setting up a docker version. then I paste the workflow and check if it still happening.

best

Paul

so I tried again in n8n docker version, with the newest version. gpt-4 is not in the list… but I just have a regular API key, shouldn’t there be gpt-4 model available?

ok, i copied and pasted the opnai node from an example workflow, and it seems to work now.

1 Like

@pehaem How did you do to get gpt-4 working ?
I can’t see it in the list.
I’m using n8n cloud.

Hey @Syphax,

The node loads the models directly from OpenAI using your API key, Is it possible that your OpenAI account doesn’t have access to GPT4 from the API?

1 Like

hey,

so as it seems, the model will only show up when using the chat node from openai. when using text. only davinci and all that other stuff with show up.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.