Grafana Credential Error invalid API key

Please help - I create authorization in Grafana as described in the instructions docs.n8n, but the authorization is created with an error.

What am I doing wrong?

Thank you.
Regards, Aleksandr.

Information on your n8n setup

  • n8n version: Version 0.209.2
  • **Database you’re using (default: SQLite):**default
  • Running n8n with the execution process [own(default), main]: main
  • Running n8n via [Docker, npm,, desktop app]: Docker

Hi @asuhan, I am sorry to hear you are having trouble. I just tried out creating fresh credentials for a Grafana-hosted instance on [email protected] running via. This worked as expected for me:

So it seems your API key is indeed invalid as suggested by the error message coming from Grafana in your screenshot.

Did you possibly add any white spaces when entering it or could it have expired?

Good afternoon, MutedJam. Thank you. It turned out that I had to connect a service account and enter the token from it.

1 Like

Awesome, glad to hear you managed to sort it out. Thanks so much for confirming!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.