[Help] Can't create a row record with NocoDB node

Describe the problem/error/question

Error when I use the NocoDB node to create a record.

Note: I’ve checked the API credentials, and it is okay, so I think there might be a bug in the NocoDB node.

For your info, I am using self-hosted NocoDB instance.

What is the error message (if any)?

400 - {"msg":"Cannot destructure property 'options' of 'object null' as it is null."} - Cannot destructure property 'options' of 'object null' as it is null.
NodeApiError: Bad request - please check your parameters
    at Object.execute (/usr/local/lib/node_modules/n8n/packages/nodes-base/dist/nodes/NocoDB/NocoDB.node.js:359:27)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/packages/workflow/dist/Workflow.js:696:19)
    at /usr/local/lib/node_modules/n8n/packages/core/dist/WorkflowExecute.js:656:53

Please share your workflow

Share the output returned by the last node

  • Same as error code

Information on your n8n setup

  • n8n version: n8n ai beta version 1.19.0
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu 20.04

Hey @TAN_YONG_SHENG,

I have just given it a go using a local instance of NocoDB I have running and it appears to be ok.

Can you share what your base and table looks like? Which version of NocoDB are you using as well?

I first tried to insert this record into this table, but it failed…

And then try again with a newly created table, and it’s succeeded

I haven’t figured out why, but I will update here if I find out why. Thanks so much @Jon

1 Like

Ah, I know why aldy…

It seems like the record failed to create whenever this multi-select column is created.

Not sure if this is the normal behaviour.

Are the fields set as required maybe?

No, for my setup, I made them all nullable fields.

I missed this one, If is multi select the field may be expecting an array of items to be sent, Have you tried using something like {{ [ 'my value'] }}?

Seems like the same error

It might be worth checking the NocoDB api to see what format it expects the data in for those fields. Next update we do for that node we should maybe make this easier.

Great, thanks Jon