Help changing hostname?

I am running n8n on docker, with the following command. docker run -d -it --rm --name n8n -p 5678:5678 -v n8n_data:/home/node/.n8n

Can someone help me set up the URL so that it does not point to localhost for webhooks and OAuth Redirect URL etc? How can I change it? I cannot for the life of me find a docker compose file.

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: Latest
  • Database (default: SQLite): Default
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu

You can use this docker-compose.yml with postgres

As for the webhook urls, you can use webhook_url environment variable as documented here.

1 Like

Hey @dg92,

Welcome to the community :cake:

Give the below a go.

docker run -d -it --rm --name n8n -p 5678:5678 -e WEBHOOK_URL= -v n8n_data:/home/node/.n8n

You can also find an example compose file in the link from @physx911 or in the documentation here: Docker Compose | n8n Docs


This worked! Thank you so much :slight_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.