How can I make my process automatically loop and execute without having to manually click "executeworkflow" each time?

Problem Description:
Hello everyone, I have a question to ask you. I receive json alert information from tradingview through the webhook node, and then send it to my discorde channel webhook address through the httpRequest node. Now, after each execution, the workflow will be closed automatically, and I have to manually click “executeworkflow” to continue execution. How can I make this workflow run in an infinite loop instead of manually executing it once each time?

Another problem is that after clicking “executeworkflow”, the workflow seems to only last a few minutes before ending. Can it be set to continue after clicking once, and the workflow will continue to run unless manually closed?please help me

This is the downloaded JSON code for the workflow:

Basic Configuration Information
Server: Google Cloud 2 cores, 2GB RAM, 20GB SSD
Operating System: Ubuntu 22.04
I deployed n8nio/n8n:latest using Portainer.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

@guge862055200 , you seem to be running the workflow in test mode. Have you tried to activate it?

Once activated the webhook should be listening for incoming requests. You do need to make sure you use production endpoint of the webhook URL in TradingView. When running manually the URL typically includes the work “test”. The production URL will be the same but without “test”.

1 Like

We also have a schedule node where you can schedule when your workflow needs to run. Remember to activate your workflow for this to be automatic

@Anton_Odongo , I don’t understand why you cannot leave the workflow active as it is triggered from outside. Perhaps the outside process could run on schedule instead.

If for some reason you still have to have the workflow active only at a specific timeframe I would do it differently.

  1. Leave the workflow active
  2. Disregard any incoming data if it is not in the timeframe you need

Essentially, there is no need for Schedule Trigger.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.