How can i make webhook node active for all time in n8n?

Hi ,

To ensure continuous activation of my webhook node in response to mentions of my Slack app, how can I maintain an ongoing connection so that the webhook node consistently receives messages whenever the Slack app is mentioned?

I have successfully tested the webhook node in the n8n cloud by manually triggering it with “Execute Workflow.” However, when attempting to set it to active and providing the production URL, it indicates that it is “Not registered.”

{"code":404,"message":"The requested webhook \"GET .......579\" is not registered.","hint":"The workflow must be active for a production URL to run successfully. You can activate the workflow using the toggle in the top-right of the editor. Note that unlike test URL calls, production URL calls aren't shown on the canvas (only in the executions list)"}

I aim to keep the webhook node permanently active so that users mentioning the app can trigger the workflow, allowing me to consistently receive and process their messages. Please assist me with this matter.

1 Like

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:
  • n8n version: n8n@ai-beta
  • Database (default: SQLite): -
  • n8n EXECUTIONS_PROCESS setting : own
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud
  • Operating system: -

Hello,

You need to activate your webhook workflow. On the top right to have to activate the workflow.
When it’s activate your need to call the production URL (same of test URL but without thé test part)

Hi @Kent1 ,

Thanks for the prompt response,

Do i need to add the production URL in slack event subscription?

Currently i have added the test workflow URL. And I make the workflow as active that is located in the top right. and also i got some message after activating the workflow. Shared in the below screenshot.

Could you please guide me on this?

Screenshot 2023-12-16 at 1.06.06 PM

@Asuwini_P , yes, you need to change the Request URL in Slack app to the production URL once you activated your n8n workflow.

1 Like

Yes you need to add the production URL in slack. For the challenge part I never use slack subscription so I can’t really help you

Thank you so much for your guidance, after applying the production url in slack, I can get active message from slack

@Kent1 @ihortom

2 Likes