How could I use correct JSON additional fields in Zulip node

I try to use additional fields in Zulip node, but it says “wrong json”. Could you help me in correct json format for this?

This is my test:

With json content:

        "additionalFields": {
          "historyPublicToSubscribers": true,
          "inviteOnly": true,
          "principals": {
            "properties": [
              {
                "email": "[email protected]",
                "email": "[email protected]",
              }
            ]
          }

Hi @cmdntd987, the JSON content appears to be missing some opening and closing braces. Does the operation work when using valid JSON in the field? E.g.:

{
    "additionalFields": {
        "historyPublicToSubscribers": true,
        "inviteOnly": true,
        "principals": {
            "properties": [{
                "email": "[email protected]",
                "email": "[email protected]"
            }]
        }
    }
}
1 Like

It 's ok now.
But it does not not effect, like without json option… I think it could not update additional fields for stream update option, because of lack of API.
chrome_Ct6kVXL43T

Hi @cmdntd987, I had a quick look at the Zulip API documentation on updating a stream. Have you tried using the exact field names in there? E.g. instead of additionalFields.historyPublicToSubscribers use history_public_to_subscribers like so?

{
    "history_public_to_subscribers": true
}

I couldn’t find support for the other fields mentioned in the Zulip API documentation on updating a stream, so you might be right on this not being supported by their API.

Do not think the additionalFields key is needed there.

1 Like

I solved this.
Just recreate, not update.