How do I authorize my n8n slack bot

has anyone successfully gone through the slack node configuration? my bot needs to be authorized in my slack demo workspace and it just never shows up in my list of bots to be authorized. I know this is likely more of a slack question but just curious if anyone has it working.

Hey @jcalcada,

I set one up yesterday for testing some workflows.

If you go here: Slack API: Applications | Slack and create your app then go to Settings > Install App on the page for the app you should be good to go.

image

1 Like

thanks for the reply @jon i got this feeling its a restriction i have here at my work. when I attempt to do that I get this…and in the “manage apps” there is no entry for my n8n bot. Its likely some permission limitation I have even though I created the workspace I’m attempting to tie it to. I’ll let you know what it is once I get it working.

Hey @jcalcada,

That is odd that looks like Slack is saying you are not an admin of the workspace you are trying to install the app into.

Is it trying to add it to another workspace? Are you doing from the build app page rather than the manage apps as well?

no - it’s trying to link to the right workspace. i’m doing the build from the app page. my helpdesk needs to still get back to me. I’ll let you know if it’s an issue in my org.

1 Like

hi - so our admin gave me permission to add a bot but now the configuration is failing. It’s because the redirect uri needs to be https: in building the slack bot call back url.
Has anyone found a way to allow n8n to connect to slack through oauth?

Hey @jcalcada,

That is strange, Normally if you create the workspace you get the owner role which is higher than admin. I wonder if maybe there was another owner that demoted your user to a standard user… anyway with that message it would suggest you have not configured the n8n webhook url environment variable.

How are you running n8n and which environment options have you set (assuming it isn’t cloud)?

ya, i’m running it locally on a docker image - that might be the problem since the docker image is accessed via http (not https). I’ll try doing it on the cloud.

Works like a charm on the cloud. I’ll see if I can get the docker to use https.

1 Like

What you could do is pop it on a server and put nginx or another reverse proxy in front of it and you should be good to go.

Hey got the same issue here on the desktop app: I switched the Tunnel URL to http://localhost:5679/workflow (so it always works with my Google account), but it prevents me to enter the URL on Slack (as it requires a https). Is there a workaround for desktop app ?

Hack solution:

  • disable the locahost webtunnel
  • use the auto generated URL
  • paste it to Slack bot
  • reconnect n8n to Slack
  • re-activate the locahost path

Don’t know if it will work on the long run

1 Like