How to Add a Cooldown Time to Workflows (Anti-Spamming)?

Describe the problem/error/question

Is there a way to add a cooldown period to a workflow, so as to prevent frequent Webhook triggering? Like only allow one successful execution every 10 minutes.

What is the error message (if any)?

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.1.1
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Debian

Hi @Bonislaw :wave: This is a little tricky with webhooks - can you take a look at this thread and see if maybe this has a solution for you?

1 Like

Thanks for providing this idea. This does seem like a tricky question since this solution introduces many extra factors.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.