How to change node's default timeout (for exemple on s3)?

Context

As you can see (in the following screenshot) i reached the timeout of and S3 call. No matter why… shit happens, I’d like to accept the fact that this issue can happen and just retry. But i want to fail faster than 300 seconds.

Question

How can i change the default timeout for the s3 node? ( i can’t find it in the settings neither in the documentation for the node)

Information on your n8n setup

  • n8n version: 0.193.5
  • Database you’re using (default: SQLite): postgresql
  • Running n8n with the execution process [own(default), main]: worker mode
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: onprem k8s install

Hi @William_Guerzeder, I am afraid most nodes don’t allow setting a node-specific time out that actually cancels an operation after a given time. An exception would be the HTTP Request node which has a timeout setting:

image

So, if your use case requires setting a timeout for an S3 API operation you could consider using this node. You would have to specify the respective request yourself but can attach your existing AWS credentials if needed:

image