How to change webhook url for self host n8n npm on windows 10

how to change webhook URL for self host n8n via npm on windows 10, when i create a new webhook it shows URL = http://localhost:5678/webhook/b8ef5867-c1d4-4483-9b4b-0034d56f6b6e
I want to change it with my domain i.e. URL=
currently, I am accessing my n8n through nginx reverse proxy


Information on your n8n setup

  • n8n version:0.216.0
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • **Running n8n via [npm]

Hi @Tehseen_Ahmad_CEng, welcome to the community :tada:

This URL can be overwritten by setting the WEBHOOK_URL environment variable. So if your n8n instance lives at you would set WEBHOOK_URL= as suggested in the docs:

Let me know if you run into any trouble with this :slight_smile:

Thanks for your prompt response :slightly_smiling_face:

i got this error

Hi @Tehseen_Ahmad_CEng, I don’t think you can set environment variables on PowerShell using the export command.

Can you try a command like below (replacing npx [email protected] with the actual command you are using to start n8n)?

$env:WEBHOOK_URL=''; npx [email protected]

Just tried this on my Windows machine and it worked:

You can also set environment variables through the Windows UI if you prefer (described for example here).

1 Like

Thanks for your support :+1:
problem resolved

1 Like

Glad to hear, thanks for confirming :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.