How to Execute PostgreSQL query only once?

Describe the problem/error/question

In the workflow that I have created there is a node which fires a SQL query to insert data in PostgreSQL. But this node gets fired/executed as many times as then number of data item in the previous node.

This is leading to creating of duplicate entries in the database.

Is there any way by which we can force the node to execute only once irrespective of number of data items it receives from previous node?

Please share your workflow


I have highlighted the number of data items the Postgres1 node receives. and thus is executed.

I have found a solution.

I enabled the settings for this node to Execute Once.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.