How to get new rows in Google Sheets?

I have to get message when Google Sheets get updated containing new row.

Hello everyone! I have a problem. I have to be notified when google sheets gets updated with telegram message containing data from fresh added row.

I tried to use Google Sheets Trigger node, but I keep receiving this error:

I guess that’s because of Russian letters in the name of table and list. But I don’t have permission to change it.

Is there any chance to get notification when sheet was updated in any other way?

My workflow:

Information on your n8n setup

  • n8n version: 0.225.2
  • Database: SQLite
  • n8n EXECUTIONS_PROCESS setting: main
  • Running n8n via: Docker Compose
  • Operating system: Ubuntu

I used to have this problem with French letters in the names of column headings.
For the sheets I use, I cheated and either renamed the column names to “english” names
OR for sheets accessed by my French colleagues, I used specific columns (Col A, Col B etc.) rather than using column name heading.
I just made sure the columns never changed in the google sheets.

I was too lazy to investigate the correct solution for this…!

Hi @whitbym, I am so sorry for the trouble but couldn’t reproduce the behaviour on my own n8n instance (perhaps because I was using the wrong characters or something, I do not speak Russian unfortunately).

Could you perhaps share a dummy Google Sheet using which the error can be reproduced when running your workflow? Also, would I need to run your workflow in production mode in order to see this error or is a manual execution enough?

I think you meant to ask @Eventurum.
I used an older version when I implemented my workflow. I’ve recently updated, so I’ll re-check for my French text.

1 Like

Hello @MutedJam! Here is dummy google sheets Тестовая таблица - Google Tabellen

And the workflow with this table, with same error:

Manual execution enough

1 Like

Thank you for your answer!
Unfortunately there is still an error with Russian letters.

Have you tried using expression, instead of fixed value?

Hello @inbsp !
Yes, I have but still same error :frowning:

Thank you so much @Eventurum, I was now able to reproduce the problem when using the Trigger On → Row Added option. I’ll add this to our bug tracker for a closer look and fix. It’d be great if you could keep your example sheet online for a little bit longer so the engineering team can use it to reproduce the problem as well.

That said, polling did work for me when using Trigger On → Row Added or Updated instead:

Perhaps this is a suitable workaround for you until the problem is fixed?

1 Like

It helped! Thank you. I will leave Google Sheet available for your tests. thank you. Hope bug will be fixed. Best wishes!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

New version [email protected] got released which includes the GitHub PR 6970.